You are not logged in Log in Join
You are here: Home » Download Zope Products » Zope » Hotfix-2007-03-20 » CVE-2007-0240: Hotfix for cross-site scripting vulnerability

Log in



CVE-2007-0240: Hotfix for cross-site scripting vulnerability

A vulnerability has been discovered in Zope, where by certain types of misuse of HTTP GET, an attacker could gain elevated privileges. All Zope versions up to and including 2.10.2 are affected.


This hotfix removes the exploit by mandating that security setting alterations can only be made through POST requests. This vulnerability has been fixed in the Zope 2.8, 2.9 and 2.10 branches and all future releases of Zope will include this fix.

Do note that this patch only affects direct requests to the security methods; any 3rd-party code that calls these methods indirectly may still be affected.


We have prepared a hot fix for this problem at:

This hotfix should be installed as soon as possible.

To install, simply extract the archive into your Products directory in your Zope installation.


for installation instructions.